Manual for Reactive Composer Tool RJC 1000
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RJC 1000
What
The RJC 1000 is a desktop computer tool for creating reactive music and packaging it for
distribution on iPhone and iPod Touch through the RjDj platform.
RJC 1000 provides an interface to put together musical material, add reactive effects and define
different states in a composition that can be triggered by the listener.

It is built to be a cross-platform application that works on Windows, Mac and Linux, but during beta
testing there is only a Mac version.
What is RjDj and reactive music?
RjDj is a player for reactive music scenes - tracks where the musical end result is created in real
time by a combination of pre-recorded material, real time audio synthesis and sensor effects like
processed live audio sampling or accelerometer control of parts of the music. RjDj is a free
application available for iPhone and iPod Touch.

Overview
The RJC 1000 provides an interface to compose and experiment with reactive music, and get the
result into RjDj for testing or distribution.

Pads
The RJC 1000 is inspired by the Akai MPC series of music production tools, and gives reactive
composers access to a number of pads that can be assigned to musical components like loops
and beats, but also to specifically reactive musical elements like reactive synthesizers or
augmented audio effects. A pad or a row of pads can be turned on/off to experiment with different
soundscapes and how the reactive components fit with other musical elements.
Modules
The RJC 1000 comes with a number of modules that can be assigned to the pads out of the box,
including a number of the best reactive reality effects and reactive synthesizers from inhouse RjDj
scene productions. More modules will be added in the future.
Pages
A certain configuration of active pads can be assigned to one of the 4 avaliable pages, for quick
switching between different states in the music. When a scene is exported from RJC 1000, the
pages go with it and the listener can swipe between the different states. Using the pages, you can
create a composition and let users activate their favorite parts of it by swiping to that page.
Scenes
The RJC 1000 can save your composition as a scene that can be played in the RjDj player on the
iPhone/iPod Touch. The listener can manually trigger states in the music by swiping between the
pages.
Scenes are installed in RjDj on the iThing by making them avaliable online and then clicking a
special install link from Safari on the iPhone/iPod Touch that opens RjDj and downloads the scene.
See the section “Installing scenes in RjDj on the iPhone or iPod Touch” for more information on
how to do this.
Expert Mode: Pure Data
RJC 1000 is a front end for the Pure Data audio programming environment and signal processing
engine, and by opening files from RJC 1000 in Pure Data you have access to a range of very
powerful configurations, tweaks and detailed control over the output. See the “Expert Mode: Pure
Data” section below for more details on how this works.

Manual
Installing RJC 1000
Mac:
When you have downloaded the RJC zip file, unzip it and move the RJC 1000 application to your
Applications folder.
Launch the application by double clicking the icon.

Headphones and microphone
To get the best use of RJC 1000, you need a microphone on your computer (built into most
laptops) and we recommend using headphones. This way youʼll hear whatʼs going on better with
reality effects, and the experience when composing using the RJC will be similar to the listening
experience on the iPhone/iPod touch.

Pads and modules
• To assign a module to a pad, drag it from the list of modules to a pad.
• Click the pad to turn the module on.
• Most modules have some parameters you can tweak. These will show up on the parameter
knobs when the pad with the module is selected.
• To see and change the settings for a module on a pad without turning on the module, right click
on the pad.
• To replace a module, just drag a new one onto the pad.
• To remove a module from a pad, click on the pad to select it, then choose “Clear active pad” from
the Edit menu.

Using pages
Pages make it easy to switch to a certain combination of active modules while making a scene in
the RJC, and also provides the user of the resulting scene a way to switch between those different
states of your composition. The idea is that you put all of the modules your scene uses onto the
pads, and then create different states that you can easliy switch between by having certain
modules on or off in the 4 avaliable pages.
Page example:

Page 1: All
modules active
Page 2: Two
modules active

The modules
assigned to the pads will stay the same. Click one of the page pads, and turn on the modules you
want on for that page. Switch to another page pad to create another arrangement.
Today switching between pages is manual both in thr RJC 1000 and RjDj, but future modules could
introduce control structures that would allow movement between pages based on for example
sensor input like walk detection, or sound levels.

Pages in RjDj on the iPhone/iPod Touch

The pages you set up in RJC will be present in the resulting scene when itʼs played in RjDj on the
iPhone/iPod Touch. The user can swipe between the different pages.
For page switching to work, you need the latest version of RjDj.
Known issues:
The swipe detection is a bit crude at the moment, this will be improved in future releases of RjDj.
Telling the user which page they are on is currently done manually by including little dots in the
graphic itself. This will also be improved in a future release.

Getting your samples and loops into RJC 1000
1) Prepare your material in your favorite audio production software. All samples need to be at
22050 Hz samplerate.

2) Drag and drop your sample onto a pad in RJC 1000. This will automatically add the sample
player module to that pad with your sample loaded into it.
The sample playback module currently takes samples and attempts to intelligently play them at the
BPM shown on the RJC-1000 by detecting hitpoints and performing some timestretching. In the
future different sample playback modes will be available.
Note on performance: For scenes to run well in RjDj, there are some memory constraints. If your
total sample material is bigger than about 20 M, youʼll likely be in trouble.

Using reality effects
RJC 1000 comes with a number modules that provide realtime effects on audio input. Drag a
module onto a pad and turn it on to try it. Many modules have parameters like delay time or filter
cutoff frequency that you can change on the knobs to the right. You can try combining several
effects to create new ones.
Note on performance: For scenes to run with good performance on the phone, there are some
limits on how many resource intensive effects you can use in a single scene. Take it easy and
make sure you test on a phone or iPod touch!

Using reality synthesizers
Reality synthesizers use sensor data for controlling some part of the sound they make. Drag one to
a pad and turn it on, you can tweak parameters on the knobs.

Saving and opening RJC projects
You can save your work as an RJC 1000 project. Choose “Save” from the File menu. The scene
will be saved as a directory with a .rjc extension. You can open the project again by choosing
“Open” from the File menu and pointing the file browser to the right .rjc directory.

Installing scenes in RjDj on the iPhone or iPod Touch
To play your scenes in RjDj on the iPhone or iPod Touch, you have two options: Installing the
scenes from your computer over a local wireless network, or upload them to RjDj.me and install
them from our servers.
In both cases, the process is to access a webpage with Mobile Safari on your device, and press a
rjdj:// link to the scene. This will launch the RjDj player, that will download and install the scene.
1) First you need to export your scene. Choose File --> Export for Web. This will export your scene
for running on a device, and also package it as an .rjz file so it can be installed by the RjDj
player from a webpage. Save the file in some convenient place on your computer.
2) Installation. Choose one of the two options:
Local network installation with RjzServer
RjzServer creates a small webpage on your computer that you can reach from your iPhone or iPod
Touch if itʼs on the same wireless network as your computer.
Download the RjzServer software from http://more.rjdj.me/RjzServer/
Launch RjzServer. It will open a page with instructions in your browser. Choose File --> Set scene
directory in RjzServer and point it to where you saved your exported rjz file.
Installation via RjDj.me
You can also upload the scene to the RjDj.me server and install it from there.

Go to http://rjdj.me/sharescene and upload your rjz file. You will get a URL for the scene that you
can launch in Safari on the iThing to install the scene.
Note: The upload form at http://rjdj.me/sharescene was initially made primarily for people wanting
to contribute scenes to RjDj for publication. Donʼt be alarmed by some of the language geared
towards this in the form, it is perfectly fine to use this upload form for just testing your scene.

Adding your own scene name and artwork
Currently the RJC 1000 doesnʼt provide an interface for editing the name, description and artwork
for your scene, but you can manually edit the files that contains this information.
Choose File--> Export for Device and save the scene. This will save a folder with the .rj extension.
Open this folder in Finder to see the contents of the scene.
image.jpg is the static cover art that represents a scene in lists and on the RjDj website. You can
replace this image with another image in the same format: a 320x320 jpeg image.
screens.jpg is the pages artwork. You can replace this image with another image in the same
format: a stitched together jpeg of four 320px screens with some indication to the user about which
page they are on.
Info.plist can be edited in any text editor, or the OS X Plist Editor application, and these are the
bits you will want to change:

<dict>
<key>info</key>
<dict>
<key>author</key>
<string>PUT YOUR NAME HERE!</string>
<key>description</key>
<string>PUT A DESCRIPTION OF YOUR SCENE HERE</string>
<key>name</key>
<string>PUT THE NAME OF THE SCENE HERE</string>
<key>category</key>
<string>RJC</string>
</dict>
</dict>
If you want to stay safe, donʼt touch any other files!
Use Rjz-server to install the scene, (it will automatically make it an rjz file for you) or zip the file,
change the fileextenstion to .rjz and upload it on http://rjdj.me/sharescene.
You can read more about RjDj file formats here:
http://trac.rjdj.me

Expert Mode: Pure Data
Many modules have extra parameters that you can edit and tweak by opening the underlying Pure
Data patch. Hereʼs how:
(Known issue: This is very complicated at the moment. In a future release, you will be able to do
this with one click)

• Drag and drop a module on to a pad in the RJC-1000. PD (running in the background) will
dynamically load this module into the relevant slot.
• Click on the RJC_main.pd window behind the RJC-1000.
• Click the [pd RJC1000.master] box.
• In the next window click the [RJC-1000.master] abstraction.
• Click on [pd $0-slots]. This brings up a list of all 16 slots in the RJC-1000.
• Select the pad you dropped the module on to (the pads are numbered 0 to 16, moving from top
to bottom first, then left to right).
• Inside the slot subpatch will be another object called [decor...] it will have the module name at the
end. Click this box.
• Click on the [$2] object within this abstraction.
• You are presented with the pd GUI for the module (Right-click it to open the full innards.)

Example: Expert Mode interface for the Circle Cutter module:

Create your own modules
You can create your own modules for RJC 1000. Modules are Pure Data patches that conform to
the RJC 1000 module standard. You can find more information on how to create modules and
download example patches and documentation at https://trac.rjdj.me/wiki/RJC1000-modules

